Getting Started with Adobe After Effects
Creative Cloud - Windows
Technology Productions Levels 4-7

Getting Started with Adobe After Effects
Creative Cloud - Windows

Table of Contents

Introduction ................................................................................................................................. 5
Learning Objectives .......................................................................................................................... 5
Planning and Setup ............................................................................................................................... 6
  Planning Your Work ....................................................................................................................... 6
  Storyboards and Scripts (Screenplays) .............................................................................................. 6
  Acquiring, Choosing, and Preparing Footage .................................................................................. 6
Project Settings .................................................................................................................................. 7
Composition Settings ......................................................................................................................... 7
Performance, Memory, and Storage Considerations ........................................................................... 8
Cross-Platform Project Considerations .............................................................................................. 8
Project File Paths .................................................................................................................................... 8
  File-Naming Conventions ............................................................................................................... 8
Resources ................................................................................................................................................ 9
Welcome Window ............................................................................................................................. 9
Preferences ............................................................................................................................................ 10
Exploring the Workspace .................................................................................................................... 12
Toolbar .................................................................................................................................................. 13
Timeline .............................................................................................................................................. 14
Importing Files ...................................................................................................................................... 14
Creating a New Composition ............................................................................................................... 17
Modifying & Animating Layer Properties within a Composition ....................................................... 18
  Inserting a Shape ............................................................................................................................ 18
Keyframing ........................................................................................................................................... 20
  Generating a Stroke ......................................................................................................................... 22
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Applying Green Screen to a Video</td>
<td>24</td>
</tr>
<tr>
<td>Saving Your Project</td>
<td>26</td>
</tr>
<tr>
<td>Rendering Your Video</td>
<td>27</td>
</tr>
<tr>
<td>Additional Help</td>
<td>32</td>
</tr>
</tbody>
</table>
Introduction

After Effects CC is an application that allows you to create dynamic, visually stunning motion graphics and cinematic visual effects. This application can be used to create 2D and 3D animation that allows you to also create dynamic text animation using the many typography tools within After Effects. It can also be used to apply nondestructive effects to video, using various tinting and adjustment methods, isolating objects from their background using rotoscoping technology, and correcting for camera shake by utilizing cutting-edge stabilization features. After Effects also integrates with several other Creative Suite applications, such as Photoshop for animating 3D layers, Premiere Pro with shared effects and copy and paste support, and Flash Professional for creating engaging web animation sequences.

Learning Objectives

After completing the instructions in this booklet, you will be able to:

- Import and organize footage
- Create, arrange, and composite layers in a composition
- Modify and animate layer properties
- Add effects and modify effect properties
- Preview those changes
- Render and export your project
Planning and Setup

The following information will help you with the planning and setup of Adobe After Effects before you begin and while working on your project. These suggestions were taken from Adobe’s website and can be further referenced at http://www.adobe.com/products/aftereffects.html.

Planning Your Work

Correct project settings, preparation of footage, and initial composition settings can help you to avoid errors and unexpected results when rendering your final output movie. Before you begin, think about what kind of work you’ll be doing in After Effects and what kind of output you intend to create. After you have planned your project and made some basic decisions about project settings, you’ll be ready to start importing footage and assembling compositions from layers based on that footage.

The best way to ensure that your movie is suitable for a specific medium is to render a test movie and view it using the same type of equipment that your audience will use to view it. For example, if your video is going to be used for a DVD, try watching it on a TV. It’s best to do such tests before you have completed the difficult and time-consuming parts of your work, to uncover problems early.

Storyboards and Scripts (Screenplays)

Before you begin shooting footage or creating animations, it is often best to start by planning your movie with storyboards and a script (screenplay). You can use Adobe Photoshop and Adobe Illustrator to create storyboards. You can use Adobe Story to collaboratively write and manage screenplays. Adobe Story also converts information from a screenplay into XMP metadata that can automate the creation of shooting scripts, shot lists, and more.

Acquiring, Choosing, and Preparing Footage

Before importing footage, first decide which media and formats you'll use for your finished movies, and then determine the best settings for your source material. Often, it’s best to prepare footage before importing it into After Effects. For example, if you want an image to fill your composition frame, configure the image in Adobe Photoshop so that the image size and pixel aspect ratio match the composition size and pixel aspect ratio. If the image is too large when you import it into After Effects, you’ll increase the memory and processor requirements of the compositions that use it. If the image is too small, you’ll lose image quality when you scale it to the desired size. See Pixel aspect ratio and frame aspect ratio. If you can shoot footage with consistent lighting and colors—and otherwise prevent the need to do a lot of tedious utility work in post-production—then you’ll have more time for creative work.

If possible, use uncompressed footage or footage encoded with lossless compression. Lossless compression means better results for many operations, such as keying and motion tracking.
Certain kinds of compression—such as the compression used in DV encoding—are especially bad for color keying, because they discard the subtle differences in color that you depend on for good blue screen or green screen keying. It’s often best to wait until the final rendering phase to use compression other than lossless compression. If possible, use footage with a frame rate that matches that of your output, so that After Effects doesn’t have to use frame blending or similar methods to fill in missing frames.

The kind of work that you’ll be doing in After Effects and the kind of output movie that you want to create can even influence how you shoot and acquire your footage. For example, if you know that you want to animate using motion tracking, consider shooting your scene in a manner that optimizes for motion tracking—for example, using tracking markers. Also consider shooting at a larger frame size than what you need for final delivery if you want "head-room" for post-production, whether for fake pans and zooms, or for stabilization.

**Project Settings**

Project settings fall into three basic categories: how time is displayed in the project, how color data is treated in the project, and what sampling rate to use for audio. Of these settings, the color settings are the ones that you need to think about before you do much work in your project, because they determine how color data is interpreted as you import footage files, how color calculations are performed as you work, and how color data is converted for final output. If you enable color management for your project, the colors that you see are the same colors that your audience will see when they view the movie that you create.

**Composition Settings**

After you prepare and import footage items, you use these footage items to create layers in a composition, where you animate and apply effects. When you create a composition, specify composition settings such as resolution, frame size, and pixel aspect ratio for your final rendered output. Although you can change composition settings at any time, it’s best to set them correctly as you create each new composition to avoid unexpected results in your final rendered output. For example, the composition frame size should be the image size in the playback medium.

If you’ll be rendering and exporting a composition to more than one media format, always match the pixel dimensions for your composition to the largest pixel dimensions used for your output. Later, you can use output modules in the Render Queue panel to encode and export a separate version of the composition for each format.
Performance, Memory, and Storage Considerations
If you work with large compositions, make sure that you configure After Effects and your computer to maximize performance. Complex compositions can require a large amount of memory to render, and the rendered movies can take a large amount of disk space to store. Before you attempt to render a three-hour movie, make sure that you have the disk space available to store it.

If your source footage files are on a slow disk drive (or across a slow network connection), then performance will be poor. When possible, keep the source footage files for your project on a fast local disk drive. Ideally, you’ll have three drives: one for source footage files, one from which the application runs, and one for rendered output.

Cross-Platform Project Considerations
After Effects project files are compatible with Mac OS and Windows operating systems, but some factors—mostly regarding the locations and naming of footage files and support files—can affect the ease of working with the same project across platforms.

Project File Paths
When you move a project file to a different computer and open it, After Effects attempts to locate the project’s footage files as follows: After Effects first searches the folder in which the project file is located; second, it searches the file’s original path or folder location; finally, it searches the root of the directory where the project is located. If you are building cross-platform projects, it’s best if the full paths have the same names on Mac OS and Windows systems. If the footage and the project are on different volumes, make sure that the appropriate volume is mounted before opening the project and that network volume names are the same on both systems. It’s best to store footage in the same folder as the project file or in another folder within that folder. Here’s a sample hierarchy:

/newproject/project_file.aep
/newproject/source/footage1.psd
/newproject/source/footage2.avi

You can then copy the new project folder in its entirety across platforms, and After Effects will properly locate all of the footage. Use the Collect Files feature to gather copies of all the files in a project into a single folder. You can then move the folder containing the copied project to the other platform.

File-Naming Conventions
Name your footage and project files with the appropriate filename extensions, such as .mov for QuickTime movies and .aep for After Effects projects. If files will be used on the Web, be sure that filenames adhere to applicable conventions for extensions and paths.
Resources
Ensure that all fonts, effects, codecs, and other resources are available on both systems. Such resources are often plug-ins. If you use a native After Effects effect in a project on one operating system, the effect will still work on the other operating system to which you’ve transferred your project. However, some third-party effects and other third-party plug-ins may not continue to operate, even if you have versions of these plug-ins on the target system. In such cases, you may need to reapply some third-party effects.

Welcome Window
The first time you open Adobe After Effects CC 2015, you will see the Welcome Window. This window is described below:

![Welcome Window](image)

1. On the left-hand side, you will see a list of Recent Projects. These serve as links to your projects on your hard drive. If this is the first time opening AE, you will see a blank area like in the image shown here.
2. On the right-hand side, you will see four options are there for you.
   a. **New Composition** - creates a new comp
   b. **Open Project** - will allow you to navigate through your files in order for you to locate a past project that you wish to open.
   c. **Help and Support** - will take you to the Adobe help section on their website.
   d. **Getting Started** - takes you to some videos to help you get started.
3. Uncheck this box if you no longer wish for the Welcome Screen to appear at startup.
Preferences

Before you begin your project, it’s important to make sure that your version of Adobe After Effects is set up properly. To do so, you will need to access the General section of your Preferences. The following shows how to do so.

1. Click Edit>Preferences>General.

   ![Figure 2 - Accessing Preferences]

2. The Preferences window appears. Here you can set up several features (see Figure 3).

3. One of the more important settings to review is the Media & Disk Cache. Click **Media & Disk Cache** to access this menu (see Figure 3).
4. Disk Cache allows AE to write important information off to your hard drive. If you wish to change the disk cache location, click **Choose Folder**. Navigate to a folder to specify which you want to only contain cache (see Figure 3).

5. Change other preferences as necessary. Once finished, click **OK** (see Figure 3).

![Figure 3 - Choosing a Disk Cache Location](image-url)
Exploring the Workspace

There are many different sections within your workspace that you want to become familiar with. Whenever a panel is active, there will be a light blue line around the panel. The section below explains some of the more important areas:

1. **Tool Bar** – Houses all of the tools that you will use to create your project (see Figure 4).
2. **Project Panel** – This panel is where you will be able to see all of the files that you have imported in After Effects for this project and any pre-compositions you may have (see Figure 4).
3. **Timeline** – This is the area in your workspace where you will do a majority of your work. In the timeline, you will keyframe your sections, add effects & presets and work with your layers (see Figure 4).
4. **Effects & Presets Panel** – This panel holds all of the default effects and presets that you can add to your project. Once you become more familiar with the After Effects program, you can add more to this panel (see Figure 4).
5. **Preview Panel** – When you are still working on your project and would like to preview what you have so far or a certain section of your project, the preview panel will help you do so. Keep in mind that when previewing something using this panel, it is not being played in real time and it will lag (see Figure 4).
6. **Composition Window** – This is the area where you will be able to see the project that you are working on (see Figure 4).
Toolbar

When using After Effects, you will use the toolbar quite often. Some of the tools have additional tools linked within them. Utilize the small gray triangles to open up the additional tools under each button.

1. **Selection Tool** – This is the most commonly used tool. It is used to select text and graphic frames and allows you to work with an object using its bounding box (see Figure 5).
2. **Hand Tool** – This allows you to grab an object in the Composition Window so that you can move it around the frame (see Figure 5).
3. **Zoom Tool** – This allows you to zoom in on your project within the Composition Window (see Figure 5).
4. **Rotation Tool** – This takes the selected object and rotates it to your desired position (see Figure 5).
5. **Unified Camera Tool** – This allows you to set up the position of your camera (see Figure 5).
6. **Pan Behind (Anchor Point) Tool** – Moves the anchor point of the object that is selected (see Figure 5).
7. **Rectangle Tool** – Creates a rectangle-shaped object. More shapes can be found by clicking on the small gray triangle in the corner (see Figure 5).
8. **Pen Tool** – Use this tool to draw a path for text or to generate a stroke (see Figure 5).
9. **Horizontal Type Tool** – Use this tool to add text to your composition (see Figure 5).
10. **Additional Tools:**
    a. **Brush Tool** – Use this tool to paint or brush a path as a design element (see Figure 5).
    b. **Clone Stamp Tool** – Use this tool to duplicate an item within the layer without creating a new layer (see Figure 5).
    c. **Eraser Tool** – Select this tool to erase a part of your composition or of a certain layer (see Figure 5).
11. **Roto Brush Tool** – Allows you to define the foreground and background of your layer (see Figure 5).
12. **Puppet Pin Tool** – Add pins to a layer to stretch and animate your layer (see Figure 5).
Timeline

The Timeline contains many elements that can be used while creating your project. Some of these elements include: switches, navigation, zooming, trimming, setting keyframes, and other basic layer properties. The following will detail the elements contained within the timeline.

![Figure 6 - Timeline](image)

1. **Current Time Display** – Shows where the time indicator is within the Timeline (see Figure 6).
2. **A/V features Panel** – Contains buttons that can be used to hide video, audio, as well as lock certain layers (see Figure 6).
3. **Layer Details** – Displays the name, contents, effects, and transform properties of the layer (see Figure 6).
4. **Show/Hide Timeline Panes** – Allows you to expand or collapse the Layer Switches Pane, the Transfer Controls Pane, and the In/Out/Duration Stretch Pane (see Figure 6).
5. **Frame Level Zoom** – Allows you to zoom in to frame level or out to the entire composition (see Figure 6).
6. **Layer Duration Bar** – Indicates how long that layer is displayed (see Figure 6).
7. **Comp Family Button** – Brings forward the comp related to this window (see Figure 6).
8. **Comp Marker Bin** – Drag this to the left to obtain a new marker (see Figure 6).
9. **Time Graph Area** – Contains the time indicator, time navigator, and displays the length of the current composition in seconds (see Figure 6).
10. **Parenting Panel** – Displays the relationship of each layer (see Figure 6).
11. **Switches Panel** – Contains the following buttons (left to right): Shy-hides layers in the timeline, Collapse Transformations (for comp layer) or continuously rasterize (for vector layer), Quality and Sampling, Effect (turns off all effects), Frame Blending, Motion Blur, Adjustment Layer, 3D Layer (see Figure 6).

**Importing Files**

After Effects gives you the ability to manipulate previously recorded files in many different ways. Please refer to the section on Acquiring, Choosing, and Preparing Footage for more information about how to prepare your footage.
To import files into After Effects:

1. Click File>Import>File (or Multiple Files, if you want to import more than one at a time).

   ![Figure 7 - Importing Files](image)

2. This will open the Import File dialog box (see Figure 8). Here you will be able to select the file(s) that you would like to bring into your project.

   **Note:** Common File Types include: PSD-Adobe Photoshop, JPG-Image/Photo file, MOV-Movie file, MP3-music or audio track, and AI-Adobe Illustrator file.

3. After you have chosen the file(s) that you wish to import, click **Import** (see Figure 8).
4. The file will then appear in your Project Panel.

Figure 9 - Imported File
Creating a New Composition

A composition is the framework for a movie. Each composition has its own timeline, with multiple layers that can represent video and audio footage, animated text and vector graphics, still images, and lights. Knowing how to properly set up your composition will make your project workflow a little faster. You will need to have some advanced planning. For example, you need to know what you want your composition size to be and how long you want the video to be. The following will show you how to setup and create a new composition for your project.

1. Click **Composition> New Composition** (see Figure 10).

![Figure 10 - New Composition](image)

2. The **Composition Settings** window will appear.
   a. **Composition Name** – This is where you name your project (see Figure 11).
   b. **Preset** – This is the format that you will export your project as. When choosing the format of your video, it is important to think about how you will be presenting your final piece. Notice it is divided up into 4 different sections: (see Figure 11).
      1. The first section is for web settings.
      2. NTSC and PAL are used for standard definition broadcast settings.
      3. If you prefer to work in High Definition, choose either HDV, DVCPro, or HDTV.
      4. This section is used for film settings.
   c. **Width and Height** – Setting the width and height will set the dimensions of your project, the amount of working space that you will have to work with. Checking the box that reads: “Lock aspect ratio to 16:9 (1.78), helps you to set your composition so that it will be in high definition (HD) (see Figure 11).
d. **Duration** – This will be the length that you want your composition to be (see Figure 11).
e. **Background Color** – This is the color of the background of your working space (see Figure 11).

3. Once you have entered in all of your composition settings, click **OK** (see Figure 11).

![Figure 11 - Composition Settings Window](image)

**Modifying & Animating Layer Properties within a Composition**

**Inserting a Shape**

1. Use your mouse and select the **Rectangle tool** button.
2. Click and hold to see the other available shapes.

![Figure 12 - Rectangle Tool](image)
3. For this example, I will select the Rectangle Tool.
4. Go to the Composition Window and click and drag to draw your rectangle (see Figure 13).
5. The color of the rectangle will default to red, but you can change the fill by clicking on the color box next to Fill (see Figure 13).

![Figure 13 - Drawing a Shape](image)

6. Use the Selection tool to click and drag your shape to the desired position. In this example, I will place it in the lower left corner so that it may be animated over time.

7. Notice that as soon as the image was drawn onto the Composition, it appeared as a Shape Layer on the layers panel.

![Figure 14 - Shape Layer](image)
Keyframing

In order to continue on with the previous steps and make the rectangle appear to move through time, you will need to create keyframes. Keyframes are used to set parameters for motion, effects, audio, and other properties when changing them over time. A keyframe marks the point in time where you specify a value for a layer property, such as special position, opacity, or audio volume. The values between keyframes are interpolated. When you use keyframes to create a change over time, you will typically use at least two keyframes—one for the state at the beginning of the change (in point), and one for the new state at the end of the change (out point).

Next to each item in the timeline, there is a triangle that when clicked, allows you to view additional properties for that option. For this example, we will be altering properties under Transform.

To add a Keyframe for Position:
1. Click the triangle next to Transform. This will open up additional properties (see Figure 15).
2. To make the object move, under Transform, click the stopwatch next to Position. A blue diamond will appear (see Figure 15).
   Note: Once you click on the Stopwatch icon to set your in point, don’t click the Stopwatch icon again. If you do so, it will clear out the points that you have previously set within your timeline. Instead, once you set your in point, you want to click the Diamond shape that appears next to the Stopwatch. Use this Diamond shape to set all other points for an option.

3. Now the coordinates, or location of the image have been recorded onto the timeline (see Figure 16).

4. From the Timeline, slide the Time Indicator to about 2 seconds (see Figure 16).
5. With the Selection tool selected, select your object from the Composition window and move it to the top center of your screen (see Figure 16).
6. Slide your **Time Indicator** back to zero seconds and then select your **Space Bar** on your keyboard to preview your animation. **Note:** The playback will be a little slow at first, as the computer is rendering the animation. If you stop the playback and hit the spacebar again, it will be played back in real time.

7. Repeat steps 4-6, moving the **Time Indicator** forward in time and moving the **object** around the **Composition Window** as you please to complete your animation.
Generating a Stroke

1. From within a Composition, create a new Shape layer by going to Layer>New>**Shape Layer**.

   ![Figure 17 - New Shape Layer](image)

   **Note:** For this example, I will be using the same Rectangle layer from the previous section.

2. To create a stroke, click the **Pen Tool**, located within the toolbar and draw a line with multiple points. This will add a new layer to your timeline section.

   ![Figure 18 - Creating a Stroke](image)

3. Once your line is drawn, go to Effects & Presets Panel>Generate>**Stroke** (see Figure 19).
4. Double click on Stroke to bring up the dialog box to view the stroke options.

5. There are several options to consider when creating a stroke. They are:
   a. **Color**: This will be the color you want the stroke to be.
   b. **Brush Size**: The thickness of the line.
   c. **Brush Hardness**: How bold you would like the line to be.
   d. **Opacity**: The percentage of transparency of the stroke.
   e. **Start**: This will be the start point for the stroke.
   f. **End**: This will be the end point for the stroke.
   g. **Spacing**: This is how you adjust the spacing between stroke segments.
   h. **Paint Style**: Has 3 options: On Original Image, On Transparent, Reveal Original Image.

6. Select your options.
Applying Green Screen to a Video

1. Import a file by going to File>Import>File.
2. Once your file is imported, click and drag it into the timeline and place it where you would like it within your layers. By doing so, this will also create a new composition.

![Figure 21 - Dragging a File to the Timeline](image)


![Figure 22 - Keylight](image)

4. Double-click on Keylight. This will bring up the dialog box to view the options available to you (see Figure 23).

5. Move the timeline indicator where you would like to begin editing and then go to the Keylight dialog box and choose the **eyedropper tool** next to Screen Colour (see Figure 23).
6. Once selected, use the **eyedropper tool** to click on the background of your video file that you would like to remove.

7. Choose a **color** in that area that covers most of the background.

8. Once most of the background is gone, hover your mouse over the number next to the Screen Gain and move the slider or to the right to remove the background.

9. When the background of your video is gone, you can place an image, movie, or color layer under your video layer in the timeline. This new layer will now show up behind your background layer.

**Note:** If the background of your video is not completely gone or doesn’t look the way you would like it to look, you can always go back and adjust the gain within the Keylight dialog box by clicking on the video layer.
Saving Your Project

It is important to save your work often. By doing so, you will reduce the risk of losing the work you have been doing.

1. To save your After Effects project, go to File>Save As>Save As.

2. This will bring up the Save As dialog box (see Figure 26).

3. Make sure that you save your project as an Adobe After Effects Project. This will allow you to go back and make changes to your project (see Figure 26).

4. Once you have renamed your file and selected where you would like it to be saved, click Save (see Figure 26).
Rendering Your Video

Once you have completed your project, you will want to render it. To render your project, you have two options. You can either Add to the Render Queue or you can Add to Adobe Media Encoder.

To Add to the Render Queue:

1. Make sure your composition is selected in the Timeline and go to Composition> Add to Render Queue.

![Add to Render Queue](image)

- Figure 27 - Add to Render Queue

2. A render queue tab will open in the timeline area.
3. In the Output Module section, click the word Lossless.

![Click Lossless](image)

- Figure 28 - Click Lossless

4. In the dialog box that comes up, leave all of the settings the same, but you want to click the drop-down arrow next to Audio Output and select the Audio Output On (see Figure 29).

5. Click OK (see Figure 29).
6. Next to the *Output To:* section, click the **drop-down** and choose **Comp Name.**
7. In the dialog box that appears, create a new folder (if necessary) or select the folder of where you would like to save your project. Click **Choose**.

![Select Folder](image)

**Figure 31 - Saving Your Project**

8. Click the **Render** button in the top right of the render queue.

![Render Queue](image)

**Figure 32 - Click Render**
To Add to Adobe Media Encoder Queue:

1. Make sure your composition is selected in the Timeline and go to Composition > Add to Adobe Media Encoder Queue.

   ![Figure 33 - Add to Adobe Media Encoder Queue](image)

2. Adobe Media Encoder will open in a separate window.
Note: Under Format, H.264 is chosen by default, as it is compatible with most devices. You can change that by clicking on the drop-down arrow to the left of the chosen format.

![Figure 34 - Video Format](image)

3. Click on the text under Output File, and it will open a Save As window, allowing you to name and save your composition.

4. Click Save.

![Figure 35 - Saving Your Video](image)
5. Click the **green play button** to render your video.

![Click the Render Button](image1.png)

**Figure 36 - Click the Render Button**

6. You can check the status of the render at the bottom right side of your screen.

![Render Status](image2.png)

**Figure 37 - Render Status**

7. Once the video is rendered, it will be saved to your specified location.